PHP 8.0.0 viene con mejoras pero tendrá costo en el código

Se ha lanzado una nueva versión mejor de PHP, con algunas cosas nuevas e interesantes pero que a simple vista se nota que obligara a reprogramar muchas cosas a nivel código.

Aunque en mi servidor de Last Dragon ya lo tengo compilado y listo para usar, no he podido migrar debido a que WordPress aun no soporta php 8 y da un “ fallo critico “

PHP 8.0 viene con numerosas mejoras y nuevas características como:

Tipos de unión
Argumentos nombrados
Expresiones coincidentes
Atributos
Promoción de inmuebles para constructores
Operador de seguridad nula
Mapas débiles
Compilación Just In Time
Y mucho, mucho más…

Sobre WordPress

WordPress Core pretende ser compatible con PHP 8.0 en la versión 5.6 (actualmente programada para el 8 de diciembre de 2020).

Sin embargo, PHP 8.0 es una actualización de versión importante con una gran cantidad de cambios que rompen la compatibilidad con versiones anteriores, y muchas características que estaban en desuso dentro de las versiones de características de PHP 7.x se han eliminado oficialmente.

¿Qué significa compatibilidad aquí?
Se ha realizado un esfuerzo significativo para hacer que WordPress 5.6 sea compatible con PHP 8 por sí solo, pero es muy probable que todavía queden problemas por descubrir.

Debido a la naturaleza del uso de WordPress y el compromiso con nuestra base de usuarios, la compatibilidad debe considerarse a los ojos de esos usuarios . El objetivo es elevar el ecosistema más amplio a un estado que sea compatible con PHP 8. Eso requiere que el software Core no solo sea compatible por sí mismo, sino que también proporcione defensas contra los problemas comunes que se observan en la transición a PHP 8, mientras continúa funciona en versiones anteriores de PHP.

También debe reconocerse que WordPress nunca se usa de forma aislada (sin ningún tema o complementos) , por lo que el hecho de que WordPress sea capaz de ejecutarse en PHP 8 no indica compatibilidad “total”.

Es imposible conocer el estado del soporte de PHP 8 dentro del ecosistema más amplio (complementos, temas, etc.). Por esa razón, WordPress 5.6 debería considerarse ” compatible beta ” con PHP 8.

“Compatibilidad beta”


Llamar a WordPress 5.6 “compatible con beta” es un buen primer paso. Hacerlo reconoce el arduo trabajo que se ha realizado para que WordPress se ejecute en PHP 8 sin problemas importantes y lograr pasar las pruebas de PHPUnit. También honra el compromiso del proyecto de ser compatible con las nuevas versiones de PHP cuando se lancen.

Al mismo tiempo, Core no puede reclamar “compatibilidad total” porque el proceso para lograr ese estado requiere una mayor cantidad de tiempo dentro del ecosistema mayor. Ahí es donde WordPress Core necesita ayuda.

Todos los desarrolladores de complementos y temas, así como las comunidades de alojamiento, deben hacer que su código sea compatible con PHP 8. Esto permitirá que WordPress logre una verdadera “compatibilidad total” antes y sin que los usuarios finales tengan que cargar con la carga.

También vale la pena señalar que se han abordado todos los problemas de compatibilidad conocidos que se identificaron mediante pruebas automatizadas o análisis estático, excepto los que se detallan más adelante en esta publicación. La cobertura de prueba automatizada de WordPress Core necesita muchas mejoras, y algunos problemas requerirán pruebas manuales de WordPress en PHP 8 bajo diferentes condiciones para descubrir.

Por las razones anteriores, se recomienda encarecidamente que pruebe minuciosamente su sitio antes de actualizar a PHP 8.

2 Comments

Responder a Christopher Castro Cancelar respuesta

Comment spam protected by SpamBam