Configurar un ruteador de internet de Cisco
By: Date: mayo 5, 2011 Categories: Consultoria y Manuales

Antes de que todos los aparatos de nateo como esos linksys ( ahora de cisco ) se auto llamaran mala mente ruteadores, cosa que son pero muy a medias, existían costosos aparatos que aun hoy dominan el internet, estos son los ruteadores que fabrica la empresa cisco y son la opción para controlar el trafico de Internet y es sobre lo que se fundamente el internet, sin ellos no habria donde conectar tu modem dsl ni los paquetes de tu navegador encontrarían el camino físico para llegar al servidor web que deseas visitar. En conclusion, son el soporte del internet y sus protocolos IP

Hace 10 años mi trabajo consistía en configurar estos mágicos aparatos pues me encargaba de una parte del telecom en ISP además de que yo mismo tenia mi propio ISP y venia internet.

Yo tuve el privilegio de estar en una época donde los Ips sobraban y a cada site le asignaban al menos 255 IP una red de 24 bits por lo que me gustaba hacerle honor a su nombre y solo rutear trafico, sin nateo ni enmascaramiento, asignarle a cada maquina una ip homologada, no como ahora que por falta de ips las redes favoritas en las oficinas son las 192.168.0.0/16

Esta es una foto de los ruteadores con los que controlo el trafico de sitios como la cueva

Cisco y RAD
Ver mas grande

A continuación voy a dejarles la configuración que usaba en un cisco serie 2500, es la configuración basica de un ruteador, donde su función es únicamente encaminar los paquetes sin natear, ni enmascarar ningun paquete, simple y puro ruteo.

A lado de algunas lineas he dejado comentarios comparativos con lo que la mayoria tiene a la mano, un GNU/Linux, por cierto con una tarjeta V35 para PC un GNU/Linux puede sustituir sin problemas un ruteador Cisco como lo haría cualquier otro sistema operativo tipo UNIX

version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname LastDragonNetwork
!
enable password aquivalaclaveadministradora  <- Esto equivale a
Root ( ENABLE )
!
!
!
!
!
ip subnet-zero
ip name-server 200.33.150.193   <- Aqui va el DNS del
Cisco, en GNU/Linux /etc/resolv.conf
!
!
!
process-max-time 200
!
!El siguiente bloque equivale a GNU/Linux ifconfig eth0 148.223.194.145
netmask 255.255.255.240
!
interface Ethernet0
ip address 148.223.194.145 255.255.255.240
no ip directed-broadcast
!
!El siguiente bloque no tiene equivalencia comun, por que es un puerto
serial, por aqui se reciben los enlaces E1
!Por medio de un modem especial llamado RAD, se encarga de gestionar la
fibra o los cobres dependiendo de la entrega del enlace
!
!La ip que se le asigna no requiere ser ruteada, La ip del otro lado
sera 148.223.192.94, la cual es la ip
!del proximo ruteador y por donde transitara la red
148.223.194.144/255.255.255.240
!
interface Serial0
ip address 148.223.192.93 255.255.255.252
no ip directed-broadcast
encapsulation frame-relay
cdp enable
frame-relay interface-dlci 85
frame-relay lmi-type ansi
!
ip classless
ip route 0.0.0.0 0.0.0.0 148.223.192.94 <- proximo router equivale
en GNU/Linux a route add default gw 148.223.192.94
!
!
line con 0
transport input none
line aux 0
line vty 0 4   <- Son lineas de terminal, aqui habilitamos
4 terminales para administrar en consola serial o telnet
password aquivalaclave <- Esto equivale a un usuario sin
privilegios, se usa para entrar, luego enable para administrar
login
!
end

2 thoughts on “Configurar un ruteador de internet de Cisco

  1. Mozilla Firefox 4.0.1 Windows 7

    Yo solo he configurado routers de la serie 1800… Y no lo veo tan dificil….

    Aunque a nosotros nos enseñaron que siempre debemos securizar primero la linea de consola, la auxiliar y las vty 0 a 4… Y ya despues todo lo que quisieramos!!

    Me encanto este articulo! Para mis favoritos, me encantarían más así, de temas sobre redes!!

    Un saludo!

  2. Mozilla Firefox 4.0.1 Windows 7

    Solo para complementar por seguridad hay que habilitar service password-encryption.

    Saludos

Responder a Rodrigo Moreno Cancelar respuesta

Tu dirección de correo electrónico no será publicada.